Wxcam 1.1 64 bits deb (Actualizado 09/oct/13)

Ya que hace mucho tiempo no escribo no les he podido contar sobre mi más reciente adquisición una Sony VPCEB1J1E

ya que tiene 4gb de ram trabajo con Ubuntu 11.04 de 64 bits (que trae una gran cantidad de beneficios que no explicare aquí)

Pues instalando como de costumbre las aplicaciones que uso a diario me encuentro que Wxcam no tiene un .deb compilado para 64 bits con lo cual me puse a investigar la forma de forzar la instalación lo cual según leí no es la mejor manera ya que el programa se ejecuta con normalidad pero sin aprovechar ninguno de los beneficios que implica trabajar con con una arquitectura de 64 bits

Así que me puse manos a la obra y me compile el programa para 64 bits y como tengo de costumbre me cree un paquete debianizado con Checkinstall por si necesitaba reinstalar o eliminar dicha versión . Así que aquí se los dejo quizá a alguien le pueda servir

Descarga: http://dl.dropbox.com/u/206277/wxcam_1.1-1_amd64.deb

Cambie el icono de la aplicación ya que me parecía desacorde con el resto. 

Actualización:

Solución Librerías faltantes: Debemos instalar algunas librerías para que el programa funcione correctamente en las versiones actuales de ubuntu, para esto ejecutaremos lo siguiente en la terminal

$ sudo aptitude install mjpegtools libwxgtk2.8-0

Luego (para solucionar el problema con las librerías nuevas, enlazaremos algunos archivos
$ sudo ln -s /usr/lib/x86_64-linux-gnu/liblavjpeg-2.0.so.0 /usr/lib/x86_64-linux-gnu/liblavjpeg-1.9.so.0
$ sudo ln -s /usr/lib/x86_64-linux-gnu/libmjpegutils-2.0.so.0 /usr/lib/x86_64-linux-gnu/libmjpegutils-1.9.so.0

Y listo con eso el programa funcionará sin ningún problema (Probado Ubuntu 13.10 64 bits Beta)

Cuando tenga el tiempo, bajaré el código fuente de nuevo y lo compilaré de nuevo, para que no haya necesidad de enlazar las librerías. Esto, solo si es posible, ya que el programa lleva mucho tiempo sin actualizarse (06/11/2011) pero no deja de ser un gran programa.

Anuncios

26 responses to this post.

  1. Posted by nikolai on septiembre 6, 2011 at 1:39 pm

    muchisimas gracias!! ya estaba harto der cheese, es lentísimo!

    Responder

  2. Posted by nikolai on septiembre 6, 2011 at 1:54 pm

    (testeado y todo en 10.10)

    Responder

  3. Posted by EliyDani on octubre 17, 2011 at 12:54 pm

    Funciona bárbaro!!!
    Gracias!

    Responder

  4. Posted by Eliydani on mayo 11, 2012 at 10:17 pm

    Gracias idolo!!!! En Ubuntu 12.04 funciona bárbaro!!!

    Responder

    • Posted by Eliydani on junio 14, 2012 at 7:22 pm

      Me retracto… Funcionó en el sentido que se instaló y me sale el ícono y todo pero al momento de hacerla andar es como que se empieza a abrir y se cierra. En realidad no anda. la probé en Linux Mint 13 y tampoco. Sería bueno ver como se puede arreglar.

      Salu2!

      Responder

  5. Posted by diego on junio 9, 2012 at 7:46 pm

    valeeeeeeeeeeeeeeeeeee!!!
    en linux mint 12 kde funcionando

    Responder

  6. Posted by meiko on junio 20, 2012 at 6:33 pm

    wxcam: error while loading shared libraries: liblavjpeg-1.9.so.0: cannot open shared object file: No such file or directory

    Responder

    • Posted by Fixt on junio 20, 2012 at 8:14 pm

      sudo aptitude install libmjpegtools-1.9

      Responder

      • Posted by david on junio 21, 2014 at 9:58 am

        yo utilizo ubuntu 14.04 y no e logrado que funcione, al quererlo instalar me dice que el paquete es de mala calidad y aun asi lo instalo pero le doy en el icono y nada, ya escribi en la terminal wxcam y me da el error de wxcam: error while loading shared libraries: liblavjpeg-1.9.so.0: cannot open shared object file: No such file or directory

        ya intente esto sudo aptitude install libmjpegtools-1.9 y tambien me da error de

        $ sudo apt-get install libmjpegtools-1.9
        Leyendo lista de paquetes… Hecho
        Creando árbol de dependencias
        Leyendo la información de estado… Hecho
        E: No se ha podido localizar el paquete libmjpegtools-1.9
        E: No se pudo encontrar ningún paquete con la expresión regular «libmjpegtools-1.9»

      • Posted by Fixt on octubre 25, 2014 at 12:13 pm

        debes instalar el paquete liblavjpeg-2.1-0 y luego enlazar la librería liblavjpeg-2.1.so.0 con la liblavjpeg-1.9.so.0

  7. Posted by Tomás on agosto 3, 2012 at 9:26 am

    Exelente tu aporte, pero en mi caso, no abre al cliquear en el menú, si sabes algo, por favor avisame, he utilizado esta aplicacion en todos los sistemas operativos con éxito incluso en chakra ahora en mint13 no fifa; Gracias hermanito, saludos…..

    Responder

    • Posted by Fixt on agosto 10, 2012 at 5:46 pm

      escribe en un terminal wxcam y copia en un comentario lo que te sale.. quizá sea que te falta alguna dependencia. que versión de ubuntu utilizas?

      Responder

  8. Posted by MarcNqnArg on agosto 15, 2012 at 4:02 pm

    Hola Fixt:
    Consulta, se puede armar una pequeña red con webcams y seguirla con este programa?

    Responder

  9. Yo lo estoy intentando, pero no me deja instalarlo, me sale un aviso de ke el pakete es de mala calidad y ke puede dañar el ekipo, pero insisto y no hay manera.

    Responder

    • Posted by Fixt on enero 1, 2013 at 12:42 pm

      Deberías probar instalarlo con gdebi en lugar del Software Center

      Responder

      • ya lo he hecho, ahora lo abro y me dice:
        Un error ocurrió durante la captura.
        Checkea el “formato de fotograma” en el menu de preferencias.

        He probado todos los formatos y me dice lo mismo, he instalado gspca-soruce y nada.

  10. Muy bueno. Gracias por tu aporte!!!!

    Responder

  11. Posted by Dirk Sonne on marzo 13, 2013 at 4:59 am

    Vielen Dank !
    Thank you very much1

    Responder

  12. Posted by Juian on diciembre 3, 2013 at 5:05 pm

    excelente, gracias!!

    Responder

  13. Posted by Jesús on diciembre 10, 2013 at 10:58 am

    Gracias!! compilándolo yo no podía instalarlo. Ahora funciona aunque me da un error can’t open file ‘/home/oem/Desktop/image.tif’ (error 2: No existe el archivo o el directorio)

    Responder

  14. Posted by Juan on junio 14, 2014 at 2:24 pm

    lo instalé y el ícono aparece en el menu de inicio, pero no arranca, supuse que le faltaba lo de las librerías, así que puse esto en el terminal :

    $ sudo ln -s /usr/lib/x86_64-linux-gnu/libmjpegutils-2.0.so.0 /usr/lib/x86_64-linux-gnu/libmjpegutils-1.9.so.0
    $ sudo ln -s /usr/lib/x86_64-linux-gnu/libmjpegutils-2.0.so.0 /usr/lib/x86_64-linux-gnu/libmjpegutils-1.9.so.0

    pero dice: $ no se encontró la orden
    que puedo hacer?

    Responder

  15. Posted by Uriepero on octubre 8, 2014 at 5:39 pm

    Buenas amigo, no he podido instalar en Ubuntu 14.04.1 LTS, agradecido con toda la ayuda que pueda prestarnos, gracias…

    Responder

  16. Posted by adrian on noviembre 25, 2014 at 11:32 pm

    me funciona de maravilla, gracias.

    Responder

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: